SharePoint down every morning

Mar 16, 2009 at 6:32 PM
I'm not 100% sure if this is related to your tool or not, but I've been using this for a while now and it's been amazing. Thank you for sharing it.
However, the past few weeks, we've been running into a problem where SharePoint will not work. Every morning between 2:30 and 2:45 AM something happens and the users can login and authenticate, but when they do it throws up an error page. Here is the error we get:

Go back to site
Error



Value cannot be null.
Parameter name: value at System.String.EndsWith(String value, StringComparison comparisonType)
at Microsoft.SharePoint.ApplicationRuntime.SPRequestModule.PostAuthenticateRequestHandler(Object oSender, EventArgs ea)
at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Troubleshoot issues with Windows SharePoint Services.

IISreset fixes the issue in no time, but it comes back every day. Any thoughts?
Jul 9, 2009 at 10:10 AM

See disposing SharePoint resources issue on this project, we have the same problems on our farm.

Aug 21, 2009 at 6:07 PM

We actually got this working ok now that we've moved to a new server.

Although, it appears that alerts are not working for users that are simply added to a role which is then added to a SharePoint group. If a user is manually added to the group alerts work fine, however, if a user is only in a role, it does not work. Would your issue "disposing Sharepoint" possibly help to address this?