Login page doesn´t open

Sep 20, 2007 at 9:48 PM
You have created the feature I have looked around for a long time. Well done.

Installed everything like in instruction. The only problem was that I couldn´t find any <system.net> section in web.config file. Just for case I didn´t put there the password remainder strings, to avoid having it in wrong place. Looks like this is not so important?
Second question was, is it necessary to have .../Content/ at the end of Url in web.config files? I tried with and without, but same result.
The result was:

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Unrecognized element 'Forms'.

Source Error:

Line 108: <httpRuntime maxRequestLength="51200" />
Line 109: <authentication mode="Forms">
Line 110: <Forms loginUrl="/membership/memberlogin.aspx" />
Line 111: </authentication>
Line 112: <identity impersonate="true" />_

I started all over, deleted the Web Application and restored also the Central Admin original web.config file.
After that the result was error, but this time a different one: 404 NOT FOUND. In browser address row appeared such string: http://www.mydomainname.net/membership/memberlogin.aspx?ReturnUrl=%2f_layouts%2fAuthenticate.aspx%3fSource%3d%252f&Source=%2f
Looks like everything is ok, but it can´t open the login page. May be you can give me some advise how to solve this?

Peeter
Sep 30, 2007 at 1:02 AM
Peeter,

I think I ran into some of the same problems trying to install this. The first problem (Parser Error Message: Unrecognized element 'Forms'.) I think happens because "forms" needs to be in lower case on line 110.

The 2nd problem is because the login forms are not included in the download. So the part of the deployment guide that changes the default login page to memberlogin.aspx won't work.

I ignored that memberlogin.aspx change, and I was able to get to a login screen. I manually added a member list (the instructions say one is added on feature activation, but it didn't happen). And I manually added a user to the list. But I can't login.
Oct 3, 2007 at 11:22 AM
All,

I've uploaded a memberlogin.aspx page as a patch.

Peeter - thanks for the lowercase forms catch - that probably saved me several hours if not longer.

I also saw the following issue - if I installed the WSP provided in releases then everything works perfectly. However, compiling the source and installing the resulting WSP fails - the features will not activate - each saying that another feature must be activated first. I have not had time to troubleshoot this as yet.

Regards,
Harold - aka Butch
Dec 7, 2007 at 2:23 PM
Edited Dec 7, 2007 at 2:25 PM
nothing
Feb 5, 2008 at 4:44 AM
Hi,
I have made following changes in web.config file bt how to upload a memberlogin.aspx page as a patch

<authentication mode="Forms">
<forms loginUrl="/membership/memberlogin.aspx" />
</authentication>
anybody can suggest me steps for this ....

Regards ,
Vinaya1
Feb 5, 2008 at 11:22 AM
Vinaya - go to the Source tab. You'll find the Patch link there.
Regards.


Vinaya1 wrote:
Hi,
I have made following changes in web.config file bt how to upload a memberlogin.aspx page as a patch

<authentication mode="Forms">
<forms loginUrl="/membership/memberlogin.aspx" />
</authentication>
anybody can suggest me steps for this ....

Regards ,
Vinaya1

Feb 6, 2008 at 3:56 AM


HaroldPGray wrote:
Vinaya - go to the Source tab. You'll find the Patch link there.
Regards.


Vinaya1 wrote:
Hi,
I have made following changes in web.config file bt how to upload a memberlogin.aspx page as a patch

<authentication mode="Forms">
<forms loginUrl="/membership/memberlogin.aspx" />
</authentication>
anybody can suggest me steps for this ....

Regards ,
Vinaya1





Hi ,
Thanks for Your help
Regards,
Vinaya
Feb 29, 2008 at 7:30 PM
Sorry for not getting this, but how do I deploy the membershiplogin.aspx into the sharepoint site?
Mar 1, 2008 at 12:44 AM
NM - I got it going, I needed to fix my webconfig, I did not have the correct list specified as the "source" for the member list. beyond that, I just copied the login page provided under the layouts folder and pathed to it in the web.config and it is good to go. be sure to mark your users as active or they wont work. i did not have any luck with the master user settings in web.config either - i just left everything as windows auth went in and setup a couple users in the list then flipped it back to forms auth. still cant seem to make sense of the roles piece.
Mar 28, 2008 at 4:49 PM
I did step by step as in guide. downloaded a pach.
Created in my wesite folder "membership" and pasted memberlogin.aspx
But it still doesint work.
I think some configuration on memberlogin.aspx is needed. like set DestinationPageUrl and MembershipProvider
so I did
MembershipProvider="CLMembership"
DestinationPageUrl="/default.aspx"

but still nothing

Thanks for Your help
Regards,
Jurgis
Aug 14, 2008 at 7:26 AM
I didn't get memberlogin.aspx  file from source tab.
where can i get memberlogin.aspx file?.
can anyone provide the link or aspx file to download?.
Nov 8, 2008 at 9:39 PM
Please note, the documentation contains errors :(

In section "Final Web.config changes" the documentation says change to
<authentication mode=”Forms”>

<Forms loginUrl=”/membership/memberlogin.aspx” />

</authentication>
This is wrong, web.config is case sensitive.... and it should be
<authentication mode=”Forms”>

<forms loginUrl=”/-- your applicaiton path here (a) --/memberlogin.aspx” />

</authentication>

(a)
In my case I did it easy for me and just put it in the
_layouts folder, just be aware when service packs arrives...the file might be deleted/overwritten...

And also as I read from another post, check the box for
IsApproved for the user account

Thanks for a nice piece :), saved me some time!!!

Feb 16, 2009 at 4:59 AM
Hi Vinaya


sorry to say, i didnt get any patch for membershiplogin.aspx page under source code tab...

could you please upload it again and provide the link to download it.


Thx !!!

Tegbir

Feb 18, 2009 at 10:37 PM
the patch is here..

http://www.codeplex.com/SPListMP/SourceControl/PatchList.aspx